Todos los foros



 
ÍndiceNormasRegistrarseConectarse

Comparte | 
 

 Pseint

Ver el tema anterior Ver el tema siguiente Ir abajo 
AutorMensaje
lauracobo
Novato/a


Mensajes : 2

MensajeTema: Pseint   Mar Nov 14, 2017 1:02 pm

Necesito ayuda para poder programar con Pseint un programa en el que introduzcas una serie de nombres y te los ordene alfabeticamente.

Un saludo. Muchas gracias!
Volver arriba Ir abajo
Corleone
Viciadillo/a


Mensajes : 590

MensajeTema: Re: Pseint   Mar Nov 14, 2017 1:07 pm

Con Excel puedes ordenar alfabéticamente.
Volver arriba Ir abajo
ivan2000vp
Novato/a


Mensajes : 4

MensajeTema: Re: Pseint   Miér Nov 15, 2017 9:01 am

Hola, se haria asi:
Proceso ordena_lista
    Dimension lista[200]
    i<-2;
    Escribir "Introduzca las palabras para poder ordenarlas alfabeticamente";
    Leer nombre;
    lista[1]<-nombre
    Mientras nombre<>"" Hacer
        Escribir "Introduzca otra palabra";
        Leer nombre;
        Para j<-1 Hasta i-1 Con Paso 1 Hacer
            Si nombre<>lista[j] Entonces
                lista[i]<-nombre;
            Sino
                Escribir "Este nombre ya ha sido introducido";
                j<-i-1;
                i<-i-1;
            Fin Si
        Fin Para
        i<-i+1;
    Fin Mientras
    Para j<-1 Hasta i-1 Hacer
        pmenor<-j;
        Para k<-j+1 Hasta i-1 Hacer
            Si lista[pmenor]>lista[k] Entonces
                pmenor<-k;
            FinSi
        FinPara
        aux<-lista[j];
        lista[j]<-lista[pmenor];
        lista[pmenor]<-aux;
    FinPara
    Para j<-1 Hasta i Hacer
        Escribir "",lista[j];
    Fin Para
   
FinProceso
Espero que te sirva.
Volver arriba Ir abajo
 
Pseint
Ver el tema anterior Ver el tema siguiente Volver arriba 
Página 1 de 1.
 Temas similares
-
» Un bucle

Permisos de este foro:No puedes responder a temas en este foro.
Todos los foros :: Asesoría Todos los Foros :: Informática :: Prácticas TIC-
Cambiar a: